[乐意黎原创] Eclipse 提示 @Override must override a superclass method 问题解决


今天新换了一个Eclipse 版本: Build id: 20140224-0627.
把原有的工程项目导入时,在使用 @Override 出现以下错误:

The method *** of type *** must override a superclass method



编译时出现下面的错误:




百思不得其解,不知道是出了什么问题。自己google和向同事请教: 


原因是因为偶的Eclipse 默认的 Compiler是jdk5,(5不支持@Override等形式的批注), 只要把它改为1.7以上就可以了。

方法:将window->preferences->java-compiler中的Compiler compliance level修改为1.7。

1.  

2. 修改


如还不能解决: 

找到现有的工程目录:

1. 找到工程



2. 修改为:1.7



OK, 大功告成,庆祝一下。


原文地址: http://blog.csdn.net/aerchi/article/details/23163119

本文禁止采集, 转载必须请注明, 全文转载。

作者地址:http://www.aerchi.com

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读