[乐意黎原创] eclipse Kepler Selected SVN connector library is not available or cannot be loaded

 问题描述:已经安装了subversive,但是在从SCM导入maven项目时,还是提示报错(如标题),根据报错原因发现在Team》SVN中确实没有svn连接器。


                   
折腾了半天, 硬是没有结果.   后来自己google, 原来是有个对应的插件没有下载.  可以在eclipse的install new software里, 找到work with 中下面插件

 http://community.polarion.com/projects/subversive/download/eclipse/3.0/kepler-site/

选择后, 进行安装,之后既可导入工程!

发布了430 篇原创文章 · 获赞 415 · 访问量 925万+
展开阅读全文

eclipsesvn connector报错?

10-21

今天下载了subversive后把features和plugins文件夹放到eclipse的dropin文件夹中后使用SVN, 结果说我的eclipse没有svnconnector,我进入window->preference中找到了SVN选项然后点击getconnectors后 把每一个svnconnector的版本都试了下载结果弹出problems occurred while performing installationLoperation details see error log for details ,然后我又照着网上说的找了svnconnector的链接在help->install newSoftware里下载结果依然是这个错误,然后又下载了subversive-connector在help-install newsoftware里选择achieve导入也报的这个错误,这是.metadata中log文件的内容 !SUBENTRY 2 org.eclipse.equinox.p2.director 4 10053 2018-10-21 14:16:04.582 !MESSAGE Cannot complete the install because one or more required items could not be found. !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2018-10-21 14:16:04.582 !MESSAGE Software being installed: SVNKit 1.8.12 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.svnkit18.feature.group 5.0.3.I20160701-1700) !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2018-10-21 14:16:04.582 !MESSAGE Missing requirement: SVNKit 1.8.12 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.svnkit18.feature.group 5.0.3.I20160701-1700) requires 'org.eclipse.team.svn.feature.group [3.0.0.I20150317-1700,4.0.0)' but it could not be found !ENTRY org.eclipse.team.svn.core.svnnature 4 0 2018-10-21 14:16:09.190 !MESSAGE Problems occurred while performing installation: Operation details !STACK 1 org.eclipse.core.runtime.CoreException: Operation details at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3_6.resolve(PrepareInstallProfileJob_3_6.java:129) at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3_6.run(PrepareInstallProfileJob_3_6.java:97) at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119) Contains: Cannot complete the install because one or more required items could not be found. Contains: Software being installed: Native JavaHL 1.8 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 5.0.3.I20160701-1700) Contains: Missing requirement: Native JavaHL 1.8 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 5.0.3.I20160701-1700) requires 'org.eclipse.team.svn.feature.group [3.0.0.I20150317-1700,4.0.0)' but it could not be found !SUBENTRY 1 org.eclipse.equinox.p2.operations 4 10053 2018-10-21 14:16:09.191 !MESSAGE Operation details !SUBENTRY 2 org.eclipse.equinox.p2.director 4 10053 2018-10-21 14:16:09.191 !MESSAGE Cannot complete the install because one or more required items could not be found. !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2018-10-21 14:16:09.191 !MESSAGE Software being installed: Native JavaHL 1.8 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 5.0.3.I20160701-1700) !SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2018-10-21 14:16:09.191 !MESSAGE Missing requirement: Native JavaHL 1.8 Implementation (Optional) 5.0.3.I20160701-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 5.0.3.I20160701-1700) requires 'org.eclipse.team.svn.feature.group [3.0.0.I20150317-1700,4.0.0)' but it could not be found 求大佬帮助万分感谢! 问答

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览